Error crítico en el complemento de WordPress permite a los hackers ejecutar código remoto


Wordpress se caracteriza por ser uno de los principales CMS más utilizados en el mundo, y una de las grandes ventajas es la disponibilidad de complementos para potenciar más el uso de este sistema.

Sin embargo, esa misma característica hace que muchos piratas informáticos aprovechen vulnerabilidades como lo es el plugin Ad Inserter.

Ad Inserter es un complemento de administración de anuncios con muchas funciones publicitarias avanzadas para insertar anuncios en posiciones óptimas, y tiene soporte para todo tipo de anuncios, incluidos AdSense de Google, Administrador de anuncios de Google (DFP - DoubleClick para editores), Anuncios nativos de compras contextuales de Amazon, Media.net y banners rotativos.

El pasado 12 de julio el equipo Threat Intelligence, descubrió una vulnerabilidad presente en el complemento Ad Inserter, mismo que se encuentra instalado en más de 200,000 sitios web, y que este error critico permite a los atacantes ejecutar código PHP de forma remota.

"La debilidad permitió a los usuarios autenticados (suscriptores y superiores) ejecutar código PHP arbitrario en sitios web usando el complemento", según los investigadores de Wordfence.

Los atacantes autenticados que tienen acceso a un nonce (un token de una sola vez utilizado para evitar que se procesen solicitudes no deseadas repetidas, caducadas o maliciosas), pueden omitir las comprobaciones de autorización activadas por la función check_admin_referer () para acceder al modo de depuración proporcionado por el complemento Ad Inserter.

Con un nonce en la mano, y un suscriptor o una cuenta de usuario superior, un atacante ahora puede explotar la función de vista previa del anuncio enviando una carga maliciosa que contiene código PHP arbitrario, como <?php echo file_get_contents('/etc/passwd'); ?>

Los sitios web que ejecutan Ad Inserter 2.4.21 o inferior deben actualizarse a la versión 2.4.22 de inmediato, para recibir una nueva regla de firewall para protegerse contra las vulnerabilidades.

Según el blog BleepingComputer, solo en 50,000 sitios han instalado la actualización de Ad Inserter, de los más de 200,000 sitios web activos. A través de Bleepingcomputer.

Más información: Wordfence

Sígueme en Telegram, o envíame un mensaje en WhatsApp con la palabra ALTA HIIARA, para recibir más artículos como estos. ►Más información.

No hay comentarios